We would like to provide an update to our PHP upgrade plan which is scheduled for this year, and as announced to customers in our Christmas newsletter earlier in the year.

PHP is a scripting language that allows your website to run interactive content such as forums, blogs, etc and a number of popular PHP based scripts are those such as Wordpress, Joomla, Gallery, etc.

Our web servers currently run PHP v5.5, however this version is reaching end of life. Whilst v5.5 is currently supported and so receiving regular security updates, this is only until 10th July 2016.

We appreciate that server PHP upgrades can cause issues with older scripts, however PHP is a fast evolving language and we unfortunately cannot run older versions of PHP on our servers when they pose a security risk to hosted sites and our servers. We are therefore providing advance notice and are planning on upgrading to PHP v5.6 on Saturday June 25th 2016 and will continue going forwards to upgrade to the next release in turn each year a month before end of life so as to ensure that we achieve a balance of both stability and security for sites. You can find the PHP release details here: http://php.net/supported-versions.php

Details on the technical changes for this upgrade can be found here: http://php.net/manual/en/migration56.php

We recommend that you upgrade any scripts on your webspace to the latest version, which should then fully support PHP v5.6 if they are still actively developed. We also have developers available if required to provide assistance if you need any code changes to your sute for custom applications. If you think that this may be required, we would recommend speaking to us in advance of this upgrade for a quote and scheduling of work as resources may be limited due to demand around the time of the upgrade itself being performed.



Tuesday, May 10, 2016







« Back